Friday, January 6, 2017

RFH: screen that hurts my eyes

Short summary:

My eyes hurt when I use my home desktop computer - but only with this computer. This has been very long and frustrating for me, so if you think you can help, read the whole story just below, or skip to what I've tried and what I suspect might be the problem, and post comments below, or send me a mail (my adress should be quite obvious in this page).

Whole story:

Two years ago, I bought myself a new fancy motherboard (a Asus B85M-G C2) with a new fancy Intel-based processor with built-in graphics (an Intel Core i7-4770) and memory to go with it. I installed it in the place of my old AMD-based motherboard, keeping everything else (my hoard of hard drives and such) excepted the graphics card, which was not needed anymore. I immediately noticed my eyes were aching when using the computer. I was quite surprised since I had been using the screen very heavily for almost 10 years before that, without any problems. I attributed that to Intel Graphics, so I tried putting back the old graphics card, but it did not help. The situation was very frustrating, since working on the computer for an hour or so was making my eyes hurt for several days. This problem was specific to this computer, I could keep on using my computer at work and my laptop without problems.

I could use the computer using SSH from my laptop, so I could profit from the faster processor, but, hey, that wasn't how it was meant to happen. I bought another screen, also tried with one from the work, without any change. I tried using two screens at the same time (this is what I have at work), also without success, so I just kept not using the computer directly. I moved recently to a new place and tried to get that working back again, but didn't get any luck. Frustrated, I got another desktop computer and another screen, and I still have the same problem ! I also tried remounting the old motherboard with the AMD processor and the old graphics card, but that didn't bring any improvement. I just don't get it. This situation is rather frustrating for me, and it's been holding me back in my software projects for two years now (which partly explains my lack of involvement in Debian over the past few years). This post is here in the hope someone will have a idea, but also for me to keep track of what I've done and what I should.

What is puzzling me is that the computer I had before was perfectly fine, and that I have a very very similar setup at work (also with a NVIDIA graphics card) that doesn't hurt my eyes at all.

What I've tried:

Here is what I tried, you need to keep in mind that when a trial fails, my eyes keep on hurting for several days, and might trigger false positives.
  • putting back the old (NVIDIA) graphics card, buying a new one (NVIDIA as well);
  • putting back the old motherboard (but with a new OS, but maybe my eyes were too sore for a clean test);
  • using another screen (a new one from the same brand, Samsung), a Dell and a HP from my work, and a brand new Phillips;
  • using two screens at the same time;
  • using a completely different (new, based on Xeon processors and a NVIDIA graphics card) computer (with new mouse, keyboard, hard drives and so on);
  • changing house, including changing the lighting conditions, the desk, the internet provider (no, I didn't do that just because of my computer problems !);
  • changing the way I drive the screens between VGA, DVI and HDMI;
  • copying the system I have in my workplace to the new computer and booting from that system (after a few adaptations, though).

As you can guess, none of those brought any improvement.

Wild hypotheses:

  • Is that a software thing ? Is there something wrong for me in the versions of Debian dating from August 2014 and after ?
  • Is that a BIOS problem with recent computers ?
  • Is that linked to some waves (bluetooth shoudln't be on, but maybe I didn't check well enough ?)
  • Is that linked to EFI (but I also have the problems when I use legacy BIOS for booting)
  • Something weird in my home ?
  • Anything else ?

Any help will be greatly appreciated, but please don't advise going to see a doctor, I don't see how this could be a medical condition specific to my home desktop computer, unless this is a very specific psychosomatic problem.

15 comments:

Ralph Aichinger said...

Maybe it is related to font rendering (especially subpixel rendering)? Have you tried different settings for fonts?

mju said...

Just a datapoint. I noticed my eyes start to hurt a bit if the screen I am looking at is too bright or the contrast is too high. I tend to lower the contrast of screens I am using.

- (Someone who just saw this post on Planet Debian.)

Anonymous said...

"Is that a software thing ? Is there something wrong for me in the versions of Debian dating from August 2014 and after ?"

Yes! systemd! :)

Anonymous said...

Did you try to change the light bulbs? Try LED or fluorescent lamp. Maybe there is some frequency interference. Also HDMI can affect wifi signals, so maybe the reverse is also possible.

Anonymous said...

I'm with Anonymous - check/change your lighting...
If using LED - look for LEDs with a higher CRI
If using dimmed lights - check how they are dimmed - could be a "sync" issue.
Balance screen and ambient lighting.

Unknown said...

Here's a reason to see an optometrist:
If there was even a slight change in viewing distance, angle, or other conditions around the same time as your initial motherboard/graphics switch, that could be the difference between your eyes focusing comfortably or not.

As for experimentation, if you can get someone to help you out, you could start running blind trials, after some sufficient cool-down interval between tests. Placebo effects could be quite strong here.

Unknown said...

The above about the optometrist said, I would suspect something in the range of brightness, contrast, or subpixel rendering changes being the initial trigger.

Perhaps they've been persistent because the Intel drivers made some change ahead of Nvidia/AMD, whose current versions now match Intel's behavior?

There could also be interactions between vision issues and any of the above - slight differences in display character and rendering could play poorly with vision deficiencyes.

Josh Triplett said...

Did you install or change the set of installed driver packages when you switched graphics? If so, perhaps something changed in font rendering, refresh rate, or some other aspect of driving the display.

Do you have Xorg log files from before the switch? Keep them safe, and try comparing them to new log files with the old graphics card. Anything different?

I've had blurry font rendering give me an instant headache before. Do you encounter eye strain no matter what you look at on the screen, or only if you read text? (Possibly hard to distinguish, given residual effects, but it would really help narrow things down.)

Anonymous said...

I suggest you to try to eliminate various sources of Electro Magnetic emissions for the cause since the procedure should be quite simple to do, although time consuming and tedious.

1. Switch off the display, the computer and, if there are other devices nearby operating in higher frequencies than mains power (50-60 Hz) from where EME could be leaked.

2. Sit down at your computer desk and wait for eye aching. Read a book or alike but no a device on and even connected to mains.

3. Take a break and repeat. If this test (using your computer spot without any possible EM sources on) does not produce eye ache, then proceed to 4..

4. Start switching a device on, or in even smaller steps, connect to mains power but still swhitched off, and repeat from step 2.

Even the first test round should give reasonable results, if you start feeling eye pain at the spot. At least you were able to totally eliminate all nearby computer stuff as source.

Anonymous said...

Even wilder hypothesis:
How much of this is happening between the ears?

It could be that after putting up with this for some time ou became "sensitised" to the issue and now that the cause has gone away (assuming that it has...) you are left with the pain. Kind of a reverse placebo effect (it really does happen).

* Difficult to (dis)prove
* Difficult to cure

fboxnf said...

There might be something that subtly disturbs displayed image. It can be some kind of em signal from unshielded/broken device or noise in electric installation(it could be caused by noisy client device, problems with installation itself). It can cause some subtle problems including pulsating backlight, subtle blur or pulsating colours.

I would test if a computer(monitor etc.) causes same problems in other locations(outside your house/ far away from it, like work).
If it doesn't I would try connecting it in your home installation through some kind of power filter/ups(straight into it, try avoiding any additional devices in between). Does it help?

Vincent Fourmond said...

Thank you all for your comments and suggestions. Here's a global reply. In any case, I have quite a few things to try out now, I'll write another post when I have fresh data to give.

* I also thought it may be a font problem, but it probably isn't, because my eyes ache as well using a SNES emulator full screen, so no system fonts at all (and no font library);
* I spend a long time playing with contrast/luminosity, that isn't the problem;
* systemd, why not ;-) ? Is there anything specific to pure systemd installs as opposed to older systems upgraded to systemd ?
* room lighting isn't probably the problem, since I use low-consumptions bulbs as a rule, but still see the problem with halogen lamps;
* my workplace setup is almost the same as here, with the exact same refresh rates. nvidia-settings -q all gives almost the same (40k) output, barring differences in GLX, but I'm not using GLX by default (fvwm2 !). I tried using the exact same drivers, but it didn't help;
* it may be psychosomatic, I can't exclude that, although I'm surprised it wouldn't affect my eyes when looking at the laptop in the exact same conditions;
* there really could be an interference problem, although I don't see how. I will try your suggestions and also using an unplugged UPS;
* and I should try systematic trials. I hadn't thought about reading on my desk with devices shut off, that seem like a good idea.

Thanks again !

Anonymous said...

Light dimmers cause brightness variances. So does an undimmed light bulbs (at twice the AC frequency + noise). If you are doing systematic testing, use sunlight **with all other ambient light sources turned off** as a control.

Sensitivity to EMI is extremely rare on humans (to the point no positive diagnostics has ever been accepted by the international medical community: as soon as you get a hard-core scientist to design and carry the double-blind testing and data analysis, the correlation with EMI and the symptoms "disappear"), it might as well be discarded. Don't get into the EMI hysteria.

Instead, look for low-key (sometimes subliminal) disturbances to your normal senses (especially vision and touch) **and** posture (long-term tactile pressure, and mechanical movements, pressure and position).

For all we knonw, the issue could be your desk/chair + keyboard/mouse position :p Try the laptop connected to the computer keyboard and monitors, or something ;-)

Anonymous said...

Allergy? Air pushed from the new computer into your direction, maybe?

My eyes (especially the left) hurt as an early allergy symptom, before even sneezing.

Erwann said...

Salut !
And what about microwaves (µW), same like in µW-oven !? I remember that when I was using a microwave-PECVD system (lab-designed, so a little bit low on safety...), the first sign of µW leak on the system was always to be catch by the eye. In fact it's a very sensitive organ of course, and full of liquid. I was using then a µW detector after first incident, and my eyes have never been proven to be wrong in µW detection. It's a very strange impression that something is pressing your eyes.
... and of course, as you know, the µW frequency use for heating (2,45 GHz) is very close to that of modern CPU. Could there be possible that the system (CPU+MB) is µwave-leaking ?! You have to find a µW detector and check that... Of course the cage of the computer would act as a faraday protection, but who knows ?